본문 바로가기

[tip] 인자이름과 함수매개변수 이름

예전부터 한번은 집고 넘어갈려고 했는데 

그냥 넘어갔던 궁금중이 있다. 

wheel_change(partNumber: any) {
    const productName = 'dl3';
    const targetEntityName = 'product';
    this.modelSvc.loadWheel(targetEntityName, productName, partNumber, true);
}
public loadWheel(entityName: string, folderName: any, partName: any, materialAsset: boolean) {

 

인자이름은 상대적으로 구체적이게 하고 

함수의 매개변수 이름은 비교적 범용성 있게 작명해야겠다 (걍 내 경험)

'' 카테고리의 다른 글

[typescript] for each 말고 for of 를 사용하자  (0) 2019.09.10
[tip] 인자이름과 함수매개변수 이름  (0) 2019.09.10
[python] swap  (0) 2019.08.24